Version 4.1

This part of the documentation is dedicated to the use of eMapZone in its main functionality, and does not include those concerning the GPS. For a detailed presentation of GPS features (included map list, other software's import/export and GPS real time position): eMapZoneHelpGPS
Note : eMapZone offers a lot of services even without the use of a GPS. Any map can be used.

Installation

Installation program

Launch the executable corresponding to installation program and follow the installation wizard. The software itself is installed in "Program Files" and document Example.cst (cst is the file extension used by eMapZone) and its map Example.jpg are installed in the folders :

- c:\My Documents\eMapZone under Windows 95 / 98

- c:\Winnt\Profiles\<login>\Personal\eMapZone under Windows NT

Files with .CST extension are registered as "eMapZone document" after the installation. Just double-click on a CST file to open the document.

Working directory

Shortcuts created by the installation program (on the desktop and in the start menu) have their working directory specified with the location used by the example (My Documents\eMapZone). It can be changed by asking the shortcut properties and modifying the field "Start In".

By-hand installation

eMapZone is just one executable; it can be installed or moved very easily :

This will associate "CST" file extension to the eMapZone software.

Using eMapZone

Scan a map

First of all, the map must be scanned with any scanner. A 150 dpi resolution can be enough, 200 dpi is more comfortable, but the software can accept big pictures such as 4000x4000 pixels!

Here is a simple map with a GPS grid (UTM format, which is not mandatory) :

Carte passée au scanner

Launch eMapZone and select the map

Launch eMapZone, click the Map... button contained in the Route tab. BMP, JPG and GIF formats are accepted, but the JPG format gives the best results for a reasonable file size.

Picture is shown in the workspace, with a default scale (the referential, in red).

Document can be saved now with the menu File, Save (or simply hit Ctrl+S). A file name is asked the first time.

The document is a CST extension file, which does not contain the picture, but only the information added to it. The image file must be present with the CST file (if it is not, the route is accessible but without the map). The file location of the image file is saved in the CST document in the relative way, such as "..\map.jpg" if the file is in the parent folder.

Set the referential

The software must know, before entering any point, what is the map scale in order to give good evaluation of distances (and, if you use a GPS, to have correct geographical reference). Follow these steps (the Zoom can be used during these steps) :

=> click the Scale tab

The referential method

Note : the referential can present a rotation relatively with the horizontal of the picture. Computations will work the same.

If the grid is for GPS usage, the origin can be set with GPS coordinates (in meters, at the UTM format, or using degree-minutes-seconds). For more details, read eMapZoneHelpGPS. GPS coordinates are absolutely NOT mandatory if they are not known, in this case leave 0,0 in the fields.
Note that the zoom is possible during these operations.

Scale definition capture

Any known distance can be used to set the scale when GPS reference is not needed. For instance, origin can be set on a particular point, X axis on another point at a known distance, Y point set with the Auto button, and the known distance entered in the Axis length field.

In case of error, the Cancel button removes the temporary reference and nothing is changed.
The options After change, process are useful when document already contains an itinerary and will be explained later in this document. They are here to indicate how current route positions must be treated after the changes (if no route is present during scale definition, those options are greyed).
Remember to save (using Ctrl+S).
Note : the little glasses allow to quickly move the view on referential point, including during the definition.

The referential method with automatic computation

Most of the time, maps do not show any grid (road maps for instance), so it can be difficult the place a referential. It is now possible to automatically compute a referential knowing the image resolution (dpi) and its scale. Warning: this referential will not have a geographical origin (not suitable for a GPS usage).
Click the Compute button, the following dialog pops up:

Compute referential window capture

Provided the map scale (simply as shown on the map itself),  and the map scan resolution (chosen during the scanning process), the software will place automatically a standard referential, in the bottom left corner, with an optimal axis length. The software supposes that the map has no distortion.
When the Ok button is pressed, the computed scale is visible in the corner. Do not forget to click Apply button to validate scale changes.

The N-point calibration method

This method is generally used when referencing a map in a geographic way, but it is also possible to choose fictive coordinates for each point. Advise for use:
Capture N-point calibration screen

Point entry

To enter points in a route, select the Route tab. The New button makes the mouse cursor change to a cross, and allow to click at the desired position. An existing point (or a beacon) can be to force the click position: maintain the Ctrl key down while clicking.

Screen capture: point entry

Caution : do not use the insert button to add point at the end of the route because points will be added before the current position, and the tour will appear backward. This button must be used to "inlay" point in an existing route.

Altitudes of points can be entered during point input, or rather after having entered all points.

Each point can receive a name (without any length limitation) displayed on the map.
It is also possible the associate a symbol for each point using the Symb. list (look in the Options tab the Symbol Set to use).
Remember to save (Ctrl+S)

The Edit menu

Edit menu
This menu can be used during or after point input:

The File menu

File menu

Point annotations and pictures

Each point can be associated with an annotation and/or a picture. Click the last button on the tool bar (Route tab), or hit Ctrl+K (Display menu). A small window appears and allows to enter text and select a picture. This window is sizeable (as a standard window), and the notes/picture split-bar can be moved.

Capture annotation screen

The ... button allows to select a picture ; the other button allows to remove the link to picture (but the picture file itself is not removed).

When a point has an annotation and/or a picture, it is drawn in the route with a grey frame. It is possible to double-click on a point to open the annotation window. Pictures and annotations are directly used by the HTML exportation (menu File, Export) : an HTML document is created containing a table with important points and their annotations and pictures.

Annotations are saved in the CST file, but pictures remain stand-alone files. Only the link is saved (in a relative way).
Warning: if the file is chosen from a removable disk, such as a CD-ROM, the source disk will be needed in the future, in order that the picture remains visible. A better approach is to copy image files first on the same drive than the CST file itself.

On the map, when a point has a picture and/or an annotation, it is drawn with a grey (or any other colour, see Options) square around it:

Point with note square

Multiple Point Selection

Several points can be selected together, using the Ctrl key when clicking the points, or using a frame selection. The current point is always part of the selection, even if it is far away from it. So beware when deleting several points at one time: the current point is also deleted.
A multiple selection is useful:

Information frame

In the route tab, some information is always shown and live updated during route edition:
Information frame screen capture

Route sections

To cut the route into two or more part, just check the New section option on the point(s) starting the new parts:

This stands as an property of the current point: checking this box does not create a point, but only changes its state.

two section route
example of route with two sections

Notes:

Example of use:

Elevation curve

Use the Options menu, or Ctrl+D or the tool-bar button in Route tab to display the window. The curve shows the current elevation of the route and can remain opened during document editing. The window is sizeable.

Capture elevation curve
The points in the curve are clickable

The elevation curve can be drawn using a colour palette: select the required palette in the Options tab. Different palette are explained in a dedicated pargraph.

Palette in Options tab

Elevation curve with slopes palette

Route notes

Menu "Options", or Ctrl+R or tool-bar button in "Route" tab. The route notes are a general comment on the trip. It will be used in the HTML exportation and printed just under the elevation curve.

Capture route notes

Window is sizeable and can remain opened during any operation.

Beacons

Beacons are isolated points that can be placed anywhere on the map, independantly from the route. GPS users know them as waypoints. As route points, they have two coordinates, an altitude (can be unknown), a symbol and can include a image and/or textual annotation.

Beacons tab
Beacons are shown in a tree view

Basic handling

Beacons are grouped in beacon sets and are shown in a tree view. Any eMapZone document always has the Current document beacon set: it includes the beacons created and modified in the current document only. Other beacon sets can be added using the import functionnality (see below).

Beacons that do not belong to the current map (geographically) are greyed in the tree (only if a map was loaded).

Creation

Click the Create button: the mouse cursor changes as a cross, alowing to click anywhere on the map. The beacon is defaultly name 001, 002 etc. and the software immediatly start the name edition in the tree itself, as in the Windows Explorer.

Selection and multiple selections

In order to select a beacon, just click on it in the tree or the map. Many beacons can be selected together: use the classical keys Ctrl/Shift in the tree as in any Windows list. On the map, a selection rectangle can be used (as for route points).
When several balises are selected, they can be modified together: for instance, to delete them, or change their symbol.

Renaming

The name of the beacon is automatically edited just after the beacon creation. In order to rename it later, just select it in the tree (or clicking in the map), and then ckick again the tree (as in the Windows Explorer; the F2 standard key can also be used). The validate, hit Enter, to cancel hit Escape.
Note that the name can be empty or contain as many chars as needed.

Moving

To change beacon position, just drag and drop in the map. All selected beacons will be moved.
It is also possible the change the coordinate in the Beacon tab. When the map has a real geographical reference, the list under the Create/Delete buttons proposes different formats and grids for the coordinates.

Altitude

The beacon altitude can be know or not. When known, it can be entered when unckecking the Unknown box.

Symbol

Beacons are by default drawn using a circle with an inner cross. A symbol can be chosen using the Symb. list. The symbols shown in this list are a subset of all possible symbols that can be changed in the Options tab, list Symbol Set.
See the GPS Transfer help to get some more information on how are the symbols managed with a GPS.

Deleting

The Delete button is active as soon as a beacon is selected. It is possible to delete several beacons at one time. Note that a deletion can be undone using the Edit, Undo menu.

Annotation/Picture

As for route point, a beacon can be associated with a text and/or picture. Use the small button at the bottom right. It is also possible to double-click the beacon on the map to get the annotation window.

Properties of a beacon set

In the upper part of the tab, it is possible to act on the whole beacon set:

Include beacons from another file

Beacons are a kind of universal data, since the indicate geographical points that really exist. That's why it can be useful to include beacons from another eMapZone (or other format) file. In order that this feature works in an optimal (and correct...) way, beacons should contain real geographical coordinates, independent from the used map. Thus, they will be correctly placed on the map, whatever the document that they come from.
Example:

Sorting

Sort list

This list allows to choose in which order the beacons will be shown in the tree view.

Using beacons : printing, route point creation, import/export etc.

A few remarks :

Overload with other routes

Menu Display, Overload with other routes... :

Overload with other routes window

Note: before using this feature, it is preferable to calibrate maps (of the current document and maps of overloaded route) in a geographical way, in order that any route can be shown on any map.

How to use this:

Remarks:
Examples of use:

Options

Software parameters can be modified in the Options tab ; options act on screen display and printing, unit system and GPS default system.

Capture onglet Options

Apparence

Colours
Click in the list to select the element to change colour of, then click on the coloured square to show a standard colour selection dialog. Changeable colours are:
Sizes
Select in the list the element to change size of, then enter a new value in the numeric field (or simply use the spin buttons).
Other options

Palettes

The softwares proposes three color palettes that can be edited:

In the option tabs, use:

capture palette window

Symbol Sets

It is possible to restrict the symbol lists (in the Route or Beacon tabs) to the one of a particular GPS:

Garmin 12 symbols
Garmin 12

Garmin eTrex symbols
Garmin eTrex

Garmin eMap symbols
Garmin eMap

Magellan 315 symbols
Magellan 315

Magellan Nav 600 symbols
Magellan Nav 600

Magellan Meridian symbols
Magellan Meridian

Magellan Trailblazer
Magellan Trail Blazer

Magellan Sportrak symbols
Magellan Sportrak

TODO

Units options

Default GPS System

see eMapZoneHelpGPS

Undo and Set Defautls buttons

The Save button must be used to keep the new settings for the next use of eMapZone. The Set Default button reset settings as they were at the first use.

Options are saved in the eMapZone.ini file under c:\windows or c:\winnt. Registry is never used (and that's a intentional choice...). This file is editable using Start Menu, Run, type in "eMapZone.ini" : Notepad software is associated with ini files.

Printing

Menu File, Print or (Ctrl+P) shows the following window (it is entirely sizeable). Here are the four fit options :

Capture print Map
Fit ouput on the whole route


The same route, fit on the whole bitmap area


Fit output on both route and bitmap


Route printing, ouput fit on route zone included on the map

Change map: This list shows all the maps used by the route, at the same scale than the one used to work. This list is obtained using the "Map List". In the case of a long route as in the example above, the last fit option is the best to print as many documents as there are used maps.

Include Title : enable to print or not the route title and the distance/elevation information.

Scale : the Full page default option will set the map on the maximum paper size, while preserving proportions and taking into account the physical margins of the printer. A Fixed scale of any value can be chosen, but if the paper is not large enough, a warning appears red at the window bottom.

Capture curve print

Curve tab shows a preview of elevation curve print, for which it is possible to choose the scale. In this way, curves of several trips can be printed with the same scale for a quick visual comparison of their difficulty. The values entered are automatically saved in the option file if the Print button is used.

Different unit systems are proposed to fix the scale, but the vertical value is always set in the system chosen for altitudes in the software options. Note that a warning is shown if the scale makes the curves go out of the paper.

The Print button sends the map or the curve to the selected printer, depending on which tab is active. Use the Close button (or the Esc. key) to close the window. The Change button gives access to the printer selection and settings.

3D View

Capture 3D view

The 3D view is a preview in three dimensions respecting the trip scale. A grey grid is shown at the minimal altitude of the circuit and acts as a support. The "walls" are an orange gradation, the lighter colour corresponding with the maximal altitude. Named points are shown with an inclination, the text is always in front of the point of view. The referential (at the centre of the circuit frame) is yellow and never masked by over elements.

Exportation

Menu File, Export... propose to save map picture and route in a graphic file, elevation curve in different formats, and make an HTML road book.

For exportation and importation with GPSTrack/G7ToWin, see eMapZoneHelpGPS

HTML road book

Export Map and Route

Elevation curve

Data

Name	X	Y	Dist. 2D	Dist. 3D	Z

Changing map, exchanging routes

Changing map

Let's suppose that a trip was prepared on a 1/25000 map and that you need to place it on another map (of the same area) with a 1/30000 scale. Changing the scale is not complicated if a common reference exists in both maps.
You need to find this common reference on both maps. The best thing is to use a common grid, if it exists, as the UTM grid. You can also use two points common to both maps (villages, road intersections...) and place the eMapZone scale on them.

Start with the trip with the 1/25000 map. Keep the map and change the scale to the common reference. To achieve this, move the referential, leave the option "after change, process real coordinates". The scale is moved, but the points remain at the same place (their real coordinates are re-processed, as you can see in their X and Y fields in the Route tab). If necessary, you can change the axis length if referential placement needs another value.

In order to move the trip on the1/30000 map, you first need to select the new picture (Map... button of the Route tab). Then, just move the scale to the new referential points, but this time choose the option "after change, process screen positions" : points will be moved on the bitmap, but their real coordinates won't change. If everything is ok, the trip will automatically fit to the right place.

Trip exchange

To use a route made by another person with your own map, process in this way :

Miscellaneous


It is recommended to use most of these shortcuts for a good usage of eMapZone

09-2003


Back to eMapZone